HOME ARTICLES JOIN GALLERY STORE SPONSORS MARKETPLACE CONTACT US  
Register | FAQ | Search | Memberlist
Username:    Password:       Forgot your password?
BIKELAND > FORUMS > ZX12R ZONE.com > Thread: HELP! Dead ZX 12 NEW TOPIC NEW POLL POST REPLY
oldman65


Parking Attendant
Posts: 1
posted May 16, 2021 04:42 AM        
HELP! Dead ZX 12

Hello all. I am running an 02 ZX 12 in a dirt track car, and it developed a problem i cant figure out. started fine after reinstalling engine, then went very rich, wouldnt idle, black smoke, ran it down drive to test transmission repairs, thinking maybe it would clear up fuel prob too, then it died. Now, no fuel, pressure is good, 12v to injectors, but i have no ground pulse. Coils are firing as they should, I am thinking ecu, but i dont have a spare to test with. I do however have an 01, plugs are different, so i would have to use the harness also. So, my questions are anything else to check? is the 01 ecu similar in performance? and can i switch the harne/ecu without changing sensors or pickups?

  Ignore this member   
All times are America/Va < Previous Thread     Next Thread >
Quick Reply:

Email Notification: Send all replies to your email address.
BIKELAND > FORUMS > ZX12R ZONE.com > Thread: HELP! Dead ZX 12 NEW TOPIC NEW POLL POST REPLY

FEATURED NEWS   Bikeland News RSS Feed

HEADLINES   Bikeland News RSS Feed


Copyright 2000-2022 Bikeland Media
Please refer to our terms of service for further information
0.345871925354 seconds processing time